Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
linux:get_baldur_s_gate_running_on_ubuntu_linux [2018/01/19 17:37]
brian
linux:get_baldur_s_gate_running_on_ubuntu_linux [2018/08/07 15:46] (current)
brian added 18.04 update
Line 11: Line 11:
  
 <code>$ sudo apt install libjson0:i386</code> <code>$ sudo apt install libjson0:i386</code>
 +
 +==== Update for Ubuntu 18.04 ====
 +
 +It seems that the ''libjson0:i386'' package is no longer present in the 18.04 repositories. Fixing this problem is now similar to how I fixed it on Fedora. First, download the 32-bit library:
 +
 +<code>sudo apt install libjson-c-dev:i386</code>
 +
 +Next, open a Terminal and navigate to **/lib/i386-linux-gnu/**. Now create a symbolic link to ''libjson-c.so.3''.
 +
 +<code>sudo ln -s libjson-c.so.3 libjson.so.0</code>
 +
 +When you run ''start.sh'' again, you may get an error about a missing ''libssl'' library.
 +
 +<code>./BaldursGate: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory</code>
 +
 +To fix this, install the 32-bit version of the library files:
 +
 +<code>sudo apt install libssl1.0.0:i386</code>
  
 And now the game runs properly. And now the game runs properly.
  • linux/get_baldur_s_gate_running_on_ubuntu_linux.txt
  • Last modified: 2018/08/07 15:46
  • by brian